1965 - 73 Mustang Interior Colors

Metro Mustang

1965 - 73 Ford Mustang Interior Colors

1965 Mustang Interior
6022 - Bright Red | 17690 - Light Palomino
5747 - Medium Blue - Metallic | 5759 - Medium Palomino
946 - Black | 5760 - Light Ivy Gold - Metallic
5756 - Medium Ivy Gold - Metallic | 5750 - Turquoise - Metallic
5767 - White | 5742 - Light Aqua - Metallic
5748 - Light Blue | 4464 - Charcoal Black

1966 Mustang Interior
946 - Black | 5760 - Light Ivy Gold - Metallic
5756 - Medium Ivy Gold - Metallic | 5750 - Turquoise - Metallic
5767 - White | 5742 - Light Aqua - Metallic
5748 - Light Blue | 5752 - Light Turquoise - Metallic
5777 - Medium Emberglow - Metallic | 5779 - Parchment
5773 - Red | 4464 - Charcoal Black

1967 Mustang Interior
5742 - Light Aqua - Metallic | 5748 - Light Blue
5773 - Red | No Color Chip Available 5734 - Dark Gold - Metallic
5753 - Dark Aqua - Metallic | 5770 - Dark Blue - Metallic
5738 - Dark Saddle | 5778 - Light Ivy Gold - Metallic
4595 - Light Parchment | 5739 - Saddle

1968 Mustang Interior
5742 - Ligtht Aqua - Metallic | 5748 - Light Blue
5753 - Dark Aqua - Metallic | 5770 - Dark Blue - Metallic
5738 - Dark Saddle | 5778 - Light Ivy Gold - Metallic
4595 - Light parchment | 5739 - Saddle
No Color Chip Available 5798 - Dark Nugget Gold - Metallic | 5792 - Red - Flat
5732 - Red - Semi Gloss | 5800 - Light Nugget Gold

1969 Mustang Interior
5748 - Light Blue | 5800 - Light Nugget Gold
15855 - White | 15834 - Dark Ivy
No Color Chip Available 15664 - Dark Ivy - Metallic | 15847 - Dark Red
15641 - Dark Red - metallic | 15436 - Dark Blue - Metallic
5747 - Medium Blue - Metallic |

1970 Mustang Interior
5747 - Medium Blue - Metallic | No Color Chip Available 16032 - Medium Ivy Green - Metallic
No Color Chip Available 15945 - Vermillion | 15940 - Dark Ginger
15939 - Medium Ginger | 15855 - White

1971 - 1973 Mustang Interior
15940 - Dark Ginger | 15939 - Medium Ginger
No Color Chip Available 16042 - Medium Green - Metallic | 17023 - Medium Avocado
16049 - Medium Blue - Metallic | 16050 - Medium Vermillion
17022 - Light Avocado | 15855 - White

Color charts are courtesy of Metro Mustang
http://www.metromustang.com